Outage

Incident Report for Paperform

Resolved

Systems are stable, we're monitoring closely.
Posted Apr 04, 2025 - 14:32 UTC

Monitoring

We have experienced two periods of downtime between 12:00 - 12:30 and 12:55 to 1:15 UTC due to extremely high volumes of traffic. We have resolved the issue, and are monitoring closely.
Posted Apr 04, 2025 - 14:05 UTC

Investigating

We are investigating reports of 500 errors across Paperform US services
Posted Apr 04, 2025 - 12:00 UTC
This incident affected: API, Paperform Dashboard, Forms, and Submission Processing (Emails, Webhooks, Integrations).